use strict;
my $str = '+971555565454';
my $regex = qr/^(?:\+971|00971|0)(?!3|8)((?:2|3|4|5|6|7|9|50|51|52|55|56)[0-9]{7,})$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}