re = /^(?:\+971|00971|0)(?!3|8)((?:2|3|4|5|6|7|9|50|51|52|55|56)[0-9]{7,})$/
str = '+971555565454'
# Print the match result
str.match(re) do |match|
puts match.to_s
end