const regex = /^10(?:\.(?:2[0-4]\d|25[0-5]|[01]?\d\d?)){3}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^10(?:\\.(?:2[0-4]\\d|25[0-5]|[01]?\\d\\d?)){3}$', '')
const str = `10.255.123.45`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}