$re = '/^10(?:\.(?:2[0-4]\d|25[0-5]|[01]?\d\d?)){3}$/';
$str = '10.255.123.45';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);