$re = '/<pskc:KeyPackage>((?!<\/pskc:KeyPackage>).)*<pskc:IssueNo>1<\/pskc:IssueNo>.*?<\/pskc:KeyPackage>/s';
$str = '
<pskc:KeyPackage>
<testTag>val1</testTag>
<pskc:IssueNo>1</pskc:IssueNo>
<testTag2>val2</testTag2>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>2</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>3</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>1</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>2</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>3</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>1</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>2</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>3</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>1</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>2</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>3</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>1</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>2</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>3</pskc:IssueNo>
</pskc:KeyPackage>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);