import Foundation
let pattern = #"<pskc:KeyPackage>((?!<\/pskc:KeyPackage>).)*<pskc:IssueNo>1<\/pskc:IssueNo>.*?<\/pskc:KeyPackage>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<pskc:KeyPackage>
<testTag>val1</testTag>
<pskc:IssueNo>1</pskc:IssueNo>
<testTag2>val2</testTag2>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>2</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>3</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>1</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>2</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>3</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>1</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>2</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>3</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>1</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>2</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>3</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>1</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>2</pskc:IssueNo>
</pskc:KeyPackage>
<pskc:KeyPackage>
<pskc:IssueNo>3</pskc:IssueNo>
</pskc:KeyPackage>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)