#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((?<=[ )()']where)|(?<=[ )()']and)|(?<=[ )()']o[rn])|(?<=[ )()']if)|(?<=[ )()']when)|(?<=having))+(\s|\()+[)(,'+_¥£$#\@\w\[\]\.\s]+like\s*\(?\s*(('((\w|%|'{2})*)')\s*\+)*\s*@p\d+\s*(\+('%'))*\)"
Local $sString = "select * from a where #myTable$@_¥£.$@_¥£#columnName like ('%'+@p2+'%')" & @CRLF & _
"select * from a where #myTable$_¥£.$_¥£#columnName like ('%'+@p2+'%')" & @CRLF & _
"" & @CRLF & _
"(\w|\[|\]|\.|\s|'|\+|\(|\)|\,)" & @CRLF & _
"" & @CRLF & _
"select a from b where h like ('%'+@p2+'%')" & @CRLF & _
"having b.d like ('%'+@p2)" & @CRLF & _
")join c on a.b like (@p2+'%')" & @CRLF & _
" and a.b like (@p2)" & @CRLF & _
" if a like ('%abc24''as'+@p2+'%')" & @CRLF & _
" case when a like ('%'+@p2+'%') " & @CRLF & _
" " & @CRLF & _
" where (((a like ('%'+ @p2+'%'))))" & @CRLF & _
" where a + 'b' like ('%'+@p2+'%')" & @CRLF & _
" where concat(a,b) like ('%'+@p2+'%') or ltrim(a) like ('%'+@p2+'%')" & @CRLF & _
"select * from a where concat(a,b) like 'a' and c like d or ltrim(a) like ('%'+@p2+'%')" & @CRLF & _
" where isnull(ltrim(a), '0') like ('%'+@p2+'%')" & @CRLF & _
" where a + 'b' LIKe ('%'+@p2+'%')" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"vICM_EVENTlike roadshowev0like_ where upper(roadshowev0like_.EVENT_NAME) like ('%'+@p1+'%') or upper(roadshowev0like_.EVENT_SYMBOLlike) like ('%'+@p2+'%') and e_.EVENT_SYMBOLike like('%'+@p2+'%')" & @CRLF & _
"" & @CRLF & _
"from vICM_INVESTOR investor0_ where (upper(investor0_.OrgId) like ('%'+@p1+'%') or upper(investor0_.Name) like ('%'+@p2+'%')) and investor0_.IsDeactivated=@p3 order by investor0_.Name asc" & @CRLF & _
"" & @CRLF & _
" where ((h.g) + upper(concat(investor0_.OrgId, 'd') + (a.d)) like ('%'+@p1+'%') " & @CRLF & _
"" & @CRLF & _
" or upper(investor0_.Name) like ('%'+@p2+'%')) and investor0_.IsDeactivated=@p3 order by investor0_.Name asc" & @CRLF & _
"" & @CRLF & _
" where (a.b like ('%'+@p2+'%')) and d.g like ('%'+@p2+'%')" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(where a.b like ('%'+@p2)" & @CRLF & _
"" & @CRLF & _
" if a like ('%'+@p2)" & @CRLF & _
"join a on b.d like ('%'+@p2)" & @CRLF & _
"" & @CRLF & _
" // not supported" & @CRLF & _
" where a like 'b' and c like ('%'+@p2+'%')" & @CRLF & _
" where a like (' '+@p1+'%') " & @CRLF & _
"// supported" & @CRLF & _
" where a like ('%'+@p1+'%') and c like ('%'+@p2+'%')" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")