import re
regex = re.compile(r"((?<=[ )()']where)|(?<=[ )()']and)|(?<=[ )()']o[rn])|(?<=[ )()']if)|(?<=[ )()']when)|(?<=having))+(\s|\()+[)(,'+_¥£$#\@\w\[\]\.\s]+like\s*\(?\s*(('((\w|%|'{2})*)')\s*\+)*\s*@p\d+\s*(\+('%'))*\)", flags=re.IGNORECASE)
test_str = ("select * from a where #myTable$@_¥£.$@_¥£#columnName like ('%'+@p2+'%')\n"
"select * from a where #myTable$_¥£.$_¥£#columnName like ('%'+@p2+'%')\n\n"
"(\\w|\\[|\\]|\\.|\\s|'|\\+|\\(|\\)|\\,)\n\n"
"select a from b where h like ('%'+@p2+'%')\n"
"having b.d like ('%'+@p2)\n"
")join c on a.b like (@p2+'%')\n"
" and a.b like (@p2)\n"
" if a like ('%abc24''as'+@p2+'%')\n"
" case when a like ('%'+@p2+'%') \n"
" \n"
" where (((a like ('%'+ @p2+'%'))))\n"
" where a + 'b' like ('%'+@p2+'%')\n"
" where concat(a,b) like ('%'+@p2+'%') or ltrim(a) like ('%'+@p2+'%')\n"
"select * from a where concat(a,b) like 'a' and c like d or ltrim(a) like ('%'+@p2+'%')\n"
" where isnull(ltrim(a), '0') like ('%'+@p2+'%')\n"
" where a + 'b' LIKe ('%'+@p2+'%')\n\n\n"
"vICM_EVENTlike roadshowev0like_ where upper(roadshowev0like_.EVENT_NAME) like ('%'+@p1+'%') or upper(roadshowev0like_.EVENT_SYMBOLlike) like ('%'+@p2+'%') and e_.EVENT_SYMBOLike like('%'+@p2+'%')\n\n"
"from vICM_INVESTOR investor0_ where (upper(investor0_.OrgId) like ('%'+@p1+'%') or upper(investor0_.Name) like ('%'+@p2+'%')) and investor0_.IsDeactivated=@p3 order by investor0_.Name asc\n\n"
" where ((h.g) + upper(concat(investor0_.OrgId, 'd') + (a.d)) like ('%'+@p1+'%') \n\n"
" or upper(investor0_.Name) like ('%'+@p2+'%')) and investor0_.IsDeactivated=@p3 order by investor0_.Name asc\n\n"
" where (a.b like ('%'+@p2+'%')) and d.g like ('%'+@p2+'%')\n\n\n"
"(where a.b like ('%'+@p2)\n\n"
" if a like ('%'+@p2)\n"
"join a on b.d like ('%'+@p2)\n\n"
" // not supported\n"
" where a like 'b' and c like ('%'+@p2+'%')\n"
" where a like (' '+@p1+'%') \n"
"// supported\n"
" where a like ('%'+@p1+'%') and c like ('%'+@p2+'%')\n"
" \n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")