package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^0-9]?9984?[^0-9]+`)
var str = `,,9984asdf`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}