#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=-ID).+(?=.html)"
Local $sString = "http://olx.ua/obyavlenie/ischu-otdelnuyu-komnatu-dlya-dolgosrochnoy-arendy-IDmQ5Is.html" & @CRLF & _
"" & @CRLF & _
"http://SashaIDeal.ru/-IDSashaBrilliantFhtml"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")