$re = '/(?<=-ID).+(?=.html)/';
$str = 'http://olx.ua/obyavlenie/ischu-otdelnuyu-komnatu-dlya-dolgosrochnoy-arendy-IDmQ5Is.html
http://SashaIDeal.ru/-IDSashaBrilliantFhtml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);