$re = '/(?=(\s|\.|,|:|;|\?|\!|^))\1(American Tea)(?=\s|\.|,|:|;|\?|\!|$)/';
$str = 'American Tea is awesome. Do you like American Tea? love WowAmerican Tea #American Tea, American Tea, American Tea!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);