$re = '/(?<=[A-Z])[A-Z](?=[a-z])/m';
$str = 'YES-HIDETotal Maze LLC.
PLEASE SPLITThis String';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);