re = /(?<=[A-Z])[A-Z](?=[a-z])/m
str = 'YES-HIDETotal Maze LLC.
PLEASE SPLITThis String'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end