$re = '~((?=\D*\d)(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z])(?=.*[!ยง$%&/(/)]).{8,})~';
$str = 'C0nsideredAGood(!)Password';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);