re = /((?=\D*\d)(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z])(?=.*[!ยง$%&\/(\/)]).{8,})/
str = 'C0nsideredAGood(!)Password'
# Print the match result
str.match(re) do |match|
puts match.to_s
end