# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\/\/(?:\\\n|[^\n])*\n)|(?:\/\*(?:\n|\r|.)*?\*\/)|((\"|')(?:\\\\|\\\2|\\\n|[^\2])*?\2)"
test_str = ("// /*\n\n\n"
"/*\n"
" This is a multi line comment\n\n"
"// */\n\n"
"// \" qwe\" dsfdsf \"\n\n"
"// This is a single line comment\n\n\n"
"char cha1[] = \"This is a string containing a combination //\",\n"
" cha2[] = \"This has /* a fake comment */ in it\",\n"
" cha3[] = \"This is tuff because of (ignore this //) \\\n"
"line continueation\",\n"
" cha4[] = \"Handle comments in strings with \\\" escaped quotes\\\n"
"and escaped escaped escapes\";\n\n"
" char array[] = \"Handle comments in strings with \\\" escaped quotes\\\n"
"and escaped escaped escapes \\\\\";\n\n\n"
"// This is a single line comment \\\n"
"continuing on the next line\n\n\n"
"void main()\n"
"{\n"
" printf(\"Hello world!\");\n\n"
" return 0;\n"
"}\n")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.