const regex = /(?:\/\/(?:\\\n|[^\n])*\n)|(?:\/\*[\s\S]*?\*\/)|((?:R"([^(\\\s]{0,16})\([^)]*\)\2")|(?:@"[^"]*?")|(?:"(?:\?\?'|\\\\|\\"|\\\n|[^"])*?")|(?:'(?:\\\\|\\'|\\\n|[^'])*?'))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\\/\\\/(?:\\\\\\n|[^\\n])*\\n)|(?:\\\/\\*[\\s\\S]*?\\*\\\/)|((?:R"([^(\\\\\\s]{0,16})\\([^)]*\\)\\2")|(?:@"[^"]*?")|(?:"(?:\\?\\?\'|\\\\\\\\|\\\\"|\\\\\\n|[^"])*?")|(?:\'(?:\\\\\\\\|\\\\\'|\\\\\\n|[^\'])*?\'))', 'g')
const str = `// /*
/*
This is a multi line comment
// <- ignored since in a comment */
// "abc" word "
// This is a single line comment
char cha1[] = "This is a string containing a combination //",
cha2[] = "This has /* a fake comment */ in it",
cha3[] = "This is tough because of (ignore this //) \\
line continueation",
cha4[] = "Handle comments in strings with \\" escaped quotes\\
and escaped escaped escapes \\\\";
// This is a single line comment \\
continuing on the next line
void main()
{
int chInt = '\\\\b\\'';
printf("Hello world!");
cpp11_1(R"xy("/**/)xy");
cpp11_2(R"("/**/)");
cS(@"End at the right place\\" /*and ignore this */);
return 0;
}
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);