import Foundation
let pattern = #"(?:\/\/(?:\\\n|[^\n])*\n)|(?:\/\*[\s\S]*?\*\/)|((?:R"([^(\\\s]{0,16})\([^)]*\)\2")|(?:@"[^"]*?")|(?:"(?:\?\?'|\\\\|\\"|\\\n|[^"])*?")|(?:'(?:\\\\|\\'|\\\n|[^'])*?'))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
// /*
/*
This is a multi line comment
// <- ignored since in a comment */
// "abc" word "
// This is a single line comment
char cha1[] = "This is a string containing a combination //",
cha2[] = "This has /* a fake comment */ in it",
cha3[] = "This is tough because of (ignore this //) \
line continueation",
cha4[] = "Handle comments in strings with \" escaped quotes\
and escaped escaped escapes \\";
// This is a single line comment \
continuing on the next line
void main()
{
int chInt = '\\b\'';
printf("Hello world!");
cpp11_1(R"xy("/**/)xy");
cpp11_2(R"("/**/)");
cS(@"End at the right place\" /*and ignore this */);
return 0;
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)