$re = '/(?<=Titel<\/b>)(.*$)/';
$str = '<b class="ui-tabel-cell-label>Titel</b>TheString that i want';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);