use strict;
my $str = 'Clone of Iteration1 - Web app
';
my $regex = qr/(?<=Clone of )[^.]*/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";