import re
regex = re.compile(r"(?<=Clone of )[^.]*", flags=re.IGNORECASE)
test_str = ("Clone of Iteration1 - Web app\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)