using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?<!\S)[tdi]\S{5,}";
string input = @"i.e txxxxx.domain.local, dxxxxx.domain.local but at the same time it should not match with xtxxxx.domain.local or xdxxxx.domain.local";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}