$re = '/(?i)(?<!\S)[tdi]\S{5,}/m';
$str = 'i.e txxxxx.domain.local, dxxxxx.domain.local but at the same time it should not match with xtxxxx.domain.local or xdxxxx.domain.local';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);