#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/content\/(?<sitename>mysite)(?<path>\/(?:[\w-]+\/)*)(?<filename>[\w-]+\.css)"
Local $sString = "/content/mysite/filename.css" & @CRLF & _
"/content/mysite/folder1/filename.css" & @CRLF & _
"/content/mysite/folder1/folder2/filename.css" & @CRLF & _
"/content/mysite/folder1/folder2/folder3/filename.css"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")