$re = '/\/content\/(?<sitename>mysite)(?<path>\/(?:[\w-]+\/)*)(?<filename>[\w-]+\.css)/';
$str = '/content/mysite/filename.css
/content/mysite/folder1/filename.css
/content/mysite/folder1/folder2/filename.css
/content/mysite/folder1/folder2/folder3/filename.css';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);