using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+?\d{1,4}?[-.\s]?\(?\d{1,3}?\)?[-.\s]?\d{1,4}[-.\s]?\d{1,4}[-.\s]?\d{1,9}";
string input = @"lkfjlsakjfd sajfldsfk askljfa131432423422";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}