const regex = /(((0|1)?\d{1,2}|2[0-4]\d|25[0-5])\.){3}((0|1)?\d{1,2}|2[0-4]\d|25[0-5])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((0|1)?\\d{1,2}|2[0-4]\\d|25[0-5])\\.){3}((0|1)?\\d{1,2}|2[0-4]\\d|25[0-5])', 'gm')
const str = `121.93.47.51
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}