re = /(((0|1)?\d{1,2}|2[0-4]\d|25[0-5])\.){3}((0|1)?\d{1,2}|2[0-4]\d|25[0-5])/m
str = '121.93.47.51
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end