// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)’s/\_[0-9]{14}_/\_/’
").unwrap();
let string = "10.209.85.14_20160831010034_show_run.txt
10.209.85.17_20160831010057_show_run.txt
10.209.85.18_20160831010104_show_run.txt
10.209.85.19_20160831010112_show_run.txt
10.209.85.20_20160831010001_show_run.txt
10.209.85.226_20160831010224_show_run.txt
10.209.85.227_20160831010228_show_run.txt
10.209.85.228_20160831010303_show_run.txt
10.217.76.10_20160831010159_show_run.txt
10.217.76.11_20160831010159_show_run.txt
10.217.76.12_20160831010206_show_run.txt
10.217.76.13_20160831010212_show_run.txt
10.217.76.14_20160831010219_show_run.txt
10.217.76.7_20160831010119_show_run.txt
10.217.76.9_20160831010122_show_run.txt
10.217.77.226_20160831010309_show_run.txt
10.217.77.227_20160831010342_show_run.txt
10.217.77.228_20160831010417_show_run.txt
";
let substitution = "_";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}