import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s?\\battr\\s*=\\s*\"\\s*\"|\\s?\\battr\\b\\s*=(?![^=<>]*\")(?!\\s*=)|\\s?\\battr\\b(?![^=<>]*\")(?!\\s*=)";
final String string = "<img src=\"/test-image_1.jpg\" attr attr=\"test-image_1\" qwe=\"asd\" attr>\n"
+ "<img src=\"/test-image_1.jpg\" attr=\"test-image_1\" qwe=\"asd\" attr=>\n"
+ "<img src=\"/test-image_1.jpg\" attr= \"test-image_1\" qwe=\"asd\" attr=\"\">\n"
+ "<img src=\"/test-image_1.jpg\" attr= \"test-image_1\" qwe=\"asd\" attr=\" \">\n"
+ "<img attr=\"a attr b\" src=\"/test-imagalte_1.jpg\" attr qwe=\"asd\" />\n"
+ "<img src=\"/test- alt image_1.jpg\" attr=\"test-image_1\" attr= \"\" qwe=\"asd\" >\n"
+ "<img src=\"/test-image_1.jpg\" attr = \" \" asd=\" q\" attr=\"test-image_1\" attr qwe=\"asd\" >\n\n\n"
+ "<img src=\"/test-image_1.jpg\" attr= \"test-image_1\" qwe=\"asd\" attr=\" d \" attr = \" d \" attr= \" d \">\n"
+ "<img attr=\"test-image_1\" qwe=\"asd\" attr >\n"
+ "<img attr=\"test-image_1\" qwe=\"asd\" battr >\n"
+ "<img attr=\"test-image_1\" qwe=\"asd\" attrh >\n\n\n"
+ "<img attr=\"test-image_1\" qwe=\"asd\" attr >\n"
+ "<img attr=\"test-image_1\" qwe=\"asd\" attr =>\n"
+ "<img attr=\"test-image_1\" qwe=\"asd\" attr=>\n"
+ "<img attr=\"test-image_1\" qwe=\"asd\" battr = \"\" >\n"
+ "<img attr=\"test-image_1\" qwe=\"asd\" attrh= \" \" >\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}