use strict;
my $str = '<img src="/test-image_1.jpg" attr attr="test-image_1" qwe="asd" attr>
<img src="/test-image_1.jpg" attr="test-image_1" qwe="asd" attr=>
<img src="/test-image_1.jpg" attr= "test-image_1" qwe="asd" attr="">
<img src="/test-image_1.jpg" attr= "test-image_1" qwe="asd" attr=" ">
<img attr="a attr b" src="/test-imagalte_1.jpg" attr qwe="asd" />
<img src="/test- alt image_1.jpg" attr="test-image_1" attr= "" qwe="asd" >
<img src="/test-image_1.jpg" attr = " " asd=" q" attr="test-image_1" attr qwe="asd" >
<img src="/test-image_1.jpg" attr= "test-image_1" qwe="asd" attr=" d " attr = " d " attr= " d ">
<img attr="test-image_1" qwe="asd" attr >
<img attr="test-image_1" qwe="asd" battr >
<img attr="test-image_1" qwe="asd" attrh >
<img attr="test-image_1" qwe="asd" attr >
<img attr="test-image_1" qwe="asd" attr =>
<img attr="test-image_1" qwe="asd" attr=>
<img attr="test-image_1" qwe="asd" battr = "" >
<img attr="test-image_1" qwe="asd" attrh= " " >
';
my $regex = qr/\s?\battr\s*=\s*"\s*"|\s?\battr\b\s*=(?![^=<>]*")(?!\s*=)|\s?\battr\b(?![^=<>]*")(?!\s*=)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}