#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*$"
Local $sString = " dog " & @CRLF & _
" cat " & @CRLF & _
" bird" & @CRLF & _
" rodent " & @CRLF & _
" fish" & @CRLF & _
""
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)