$re = '/\s*$/m';
$str = ' dog
cat
bird
rodent
fish
';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;