#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<?[^<>]*>|<[^>]*"
Local $sString = "Strip all HTML tags from a string. HTML tags are enclosed in < and >." & @CRLF & _
"" & @CRLF & _
"The regex will be applied on a line-by-line basis, meaning partial tags will need to be handled by the regex. Don't worry about opening or closing tags; we just want to get rid of them all." & @CRLF & _
"" & @CRLF & _
"Note: This task is meant to be a learning exercise, and not necessarily the best way to parse HTML"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")