re = /<?[^<>]*>|<[^>]*/
str = 'Strip all HTML tags from a string. HTML tags are enclosed in < and >.
The regex will be applied on a line-by-line basis, meaning partial tags will need to be handled by the regex. Don\'t worry about opening or closing tags; we just want to get rid of them all.
Note: This task is meant to be a learning exercise, and not necessarily the best way to parse HTML'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end