package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*:\/\/.*|(\/\/.*)`)
var str = `http://bla
// some comment
function () { // another comment
asdf asdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}