using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?::(.*?(pass|fail).*)";
string substitution = @"\1 \U\2ED";
string input = @"
tests/test_pytest_fold.py::test_1_passes_and_has_logging_output
------------------------------------------------------------------ live log setup ------------------------------------------------------------------
INFO root:test_pytest_fold.py:52 Running test tests.test_pytest_fold...
INFO root:test_pytest_fold.py:53 Setting test up...
INFO root:test_pytest_fold.py:54 Executing test...
INFO root:test_pytest_fold.py:56 Tearing test down...
------------------------------------------------------------------ live log call -------------------------------------------------------------------
CRITICAL root:test_pytest_fold.py:63 Live military happy. View water one land until interesting leader.
ERROR root:test_pytest_fold.py:64 Kid expert show cost. Point daughter team attorney keep improve serve.
WARNING root:test_pytest_fold.py:65 Arm paper write guess close modern.
INFO root:test_pytest_fold.py:66 Recently each rich.
DEBUG root:test_pytest_fold.py:67 Attack also do far pressure address hot.
PASSED [ 31%]
tests/test_pytest_fold.py::test_2_fails_and_has_logging_output
------------------------------------------------------------------ live log setup ------------------------------------------------------------------
INFO root:test_pytest_fold.py:52 Running test tests.test_pytest_fold...
INFO root:test_pytest_fold.py:53 Setting test up...
INFO root:test_pytest_fold.py:54 Executing test...
INFO root:test_pytest_fold.py:56 Tearing test down...
------------------------------------------------------------------ live log call -------------------------------------------------------------------
CRITICAL root:test_pytest_fold.py:72 Paper such fund find international occur good deal.
ERROR root:test_pytest_fold.py:73 Today type which situation people nation develop.
WARNING root:test_pytest_fold.py:74 Rich key set point answer. Sing Republican continue bar however hundred.
INFO root:test_pytest_fold.py:75 Work level century myself piece. Share news no husband cold. Half up send board than current.
DEBUG root:test_pytest_fold.py:76 Require matter impact speech left to.
FAILED [ 34%]
This is giving me a lot of trouble. I've been digging into the more advanced aspects of regex (lookarounds, and more esoteric matching symbols like \v), but so far my teammates and I haven't come up with anything workable.
Anyone care to take a stab at it? For the above second code example, I want to match so that I get the following (testname and its outcome):
test_1_passes_and_has_logging_output PASSED
test_2_fails_and_has_logging_output FAILED";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}