import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?::(.*?(pass|fail).*)";
final String string = "\n"
+ "tests/test_pytest_fold.py::test_1_passes_and_has_logging_output\n\n"
+ "------------------------------------------------------------------ live log setup ------------------------------------------------------------------\n\n"
+ "INFO root:test_pytest_fold.py:52 Running test tests.test_pytest_fold...\n\n"
+ "INFO root:test_pytest_fold.py:53 Setting test up...\n\n"
+ "INFO root:test_pytest_fold.py:54 Executing test...\n\n"
+ "INFO root:test_pytest_fold.py:56 Tearing test down...\n\n"
+ "------------------------------------------------------------------ live log call -------------------------------------------------------------------\n\n"
+ "CRITICAL root:test_pytest_fold.py:63 Live military happy. View water one land until interesting leader.\n\n"
+ "ERROR root:test_pytest_fold.py:64 Kid expert show cost. Point daughter team attorney keep improve serve.\n\n"
+ "WARNING root:test_pytest_fold.py:65 Arm paper write guess close modern.\n\n"
+ "INFO root:test_pytest_fold.py:66 Recently each rich.\n\n"
+ "DEBUG root:test_pytest_fold.py:67 Attack also do far pressure address hot.\n\n"
+ "PASSED [ 31%]\n\n"
+ "tests/test_pytest_fold.py::test_2_fails_and_has_logging_output\n\n"
+ "------------------------------------------------------------------ live log setup ------------------------------------------------------------------\n\n"
+ "INFO root:test_pytest_fold.py:52 Running test tests.test_pytest_fold...\n\n"
+ "INFO root:test_pytest_fold.py:53 Setting test up...\n\n"
+ "INFO root:test_pytest_fold.py:54 Executing test...\n\n"
+ "INFO root:test_pytest_fold.py:56 Tearing test down...\n\n"
+ "------------------------------------------------------------------ live log call -------------------------------------------------------------------\n\n"
+ "CRITICAL root:test_pytest_fold.py:72 Paper such fund find international occur good deal.\n\n"
+ "ERROR root:test_pytest_fold.py:73 Today type which situation people nation develop.\n\n"
+ "WARNING root:test_pytest_fold.py:74 Rich key set point answer. Sing Republican continue bar however hundred.\n\n"
+ "INFO root:test_pytest_fold.py:75 Work level century myself piece. Share news no husband cold. Half up send board than current.\n\n"
+ "DEBUG root:test_pytest_fold.py:76 Require matter impact speech left to.\n\n"
+ "FAILED [ 34%]\n\n"
+ "This is giving me a lot of trouble. I've been digging into the more advanced aspects of regex (lookarounds, and more esoteric matching symbols like \\v), but so far my teammates and I haven't come up with anything workable.\n\n"
+ "Anyone care to take a stab at it? For the above second code example, I want to match so that I get the following (testname and its outcome):\n\n"
+ "test_1_passes_and_has_logging_output PASSED\n"
+ "test_2_fails_and_has_logging_output FAILED";
final String subst = "\\1 \\U\\2ED";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}