#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(([a-zA-Z0-9_\-\.]+)@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.)|(([a-zA-Z0-9\-]+\.)+))([a-zA-Z]{2,4}|[0-9]{1,3})(\]?)(\s*;\s*|\s*$))*"
Local $sString = "a@a.c" & @CRLF & _
"a@a.co" & @CRLF & _
"sbreedebd@home.pl" & @CRLF & _
"sgerrensbe@free.fr" & @CRLF & _
"eishakbf@skyrock.com" & @CRLF & _
"dstansallbg@japanpost.jp" & @CRLF & _
"mbrittanbh@amazon.co.uk" & @CRLF & _
"slauridsenbi@home.pl" & @CRLF & _
"dgrabbambj@imageshack.us" & @CRLF & _
"etossellbk@apple.com" & @CRLF & _
"smoodycliffebl@sogou.com" & @CRLF & _
"rtoothillbm@wisc.edu" & @CRLF & _
"asebbornbn@infoseek.co.jp" & @CRLF & _
"dgherardescibo@jalbum.net" & @CRLF & _
"aarnaldybp@europa.eu" & @CRLF & _
"aballantinebq@bigcartel.com" & @CRLF & _
"cgiraudatbr@phpbb.com" & @CRLF & _
"hmaccoughenbs@answers.com" & @CRLF & _
"emattessenbt@dot.gov" & @CRLF & _
"saronowbu@exblog.jp" & @CRLF & _
"ckorneichukbv@berkeley.edu" & @CRLF & _
"nroderigobw@yale.edu" & @CRLF & _
"ealeksandrevbx@netvibes.com" & @CRLF & _
"ebolterby@eepurl.com" & @CRLF & _
"cgaitherbz@theatlantic.com" & @CRLF & _
"sfeedomec0@shutterfly.com" & @CRLF & _
"ahatfullc1@ocn.ne.jp" & @CRLF & _
"mbythwayc2@whitehouse.gov" & @CRLF & _
"mleitherc3@dyndns.org" & @CRLF & _
"gtouretc4@icq.com" & @CRLF & _
"lmcnaec5@cam.ac.uk" & @CRLF & _
"tculveyc6@si.edu" & @CRLF & _
"fportwainc7@themeforest.net" & @CRLF & _
"eshivellc8@xing.com" & @CRLF & _
"mrheltonc9@howstuffworks.com" & @CRLF & _
"rrenodenca@walmart.com" & @CRLF & _
"ibaudcb@apple.com" & @CRLF & _
"amckerncc@domainmarket.com" & @CRLF & _
"aszymczykcd@vk.com" & @CRLF & _
"edittyce@patch.com" & @CRLF & _
"eibertcf@cyberchimps.com" & @CRLF & _
"apagencg@google.cn" & @CRLF & _
"bcousinsch@elpais.com" & @CRLF & _
"edockrellci@kickstarter.com" & @CRLF & _
"peasterlingcj@vkontakte.ru" & @CRLF & _
"mmoenck@mail.ru" & @CRLF & _
"nstitwellcl@admin.ch" & @CRLF & _
"mreginacm@techcrunch.com" & @CRLF & _
"fbindoncn@nps.gov" & @CRLF & _
"vpocklingtonco@seattletimes.com" & @CRLF & _
"lbarabichcp@privacy.gov.au" & @CRLF & _
"fmcbeathcq@thetimes.co.uk" & @CRLF & _
"jbohillscr@bandcamp.com" & @CRLF & _
"aworkescs@amazon.de" & @CRLF & _
"mmarusyakct@zdnet.com" & @CRLF & _
"lmcaleescu@simplemachines.org" & @CRLF & _
"bdemetzcv@illinois.edu" & @CRLF & _
"jdominiquecw@economist.com" & @CRLF & _
"easlottcx@ftc.gov" & @CRLF & _
"adewhirstcy@marriott.com" & @CRLF & _
"mstaddomcz@slideshare.net" & @CRLF & _
"aealamd0@ibm.com" & @CRLF & _
"dweblind1@youtube.com" & @CRLF & _
"palasdaird2@unesco.org" & @CRLF & _
"rfrearsond3@disqus.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")