import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([a-zA-Z0-9_\\-\\.]+)@((\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.)|(([a-zA-Z0-9\\-]+\\.)+))([a-zA-Z]{2,4}|[0-9]{1,3})(\\]?)(\\s*;\\s*|\\s*$))*";
final String string = "a@a.c\n"
+ "a@a.co\n"
+ "sbreedebd@home.pl\n"
+ "sgerrensbe@free.fr\n"
+ "eishakbf@skyrock.com\n"
+ "dstansallbg@japanpost.jp\n"
+ "mbrittanbh@amazon.co.uk\n"
+ "slauridsenbi@home.pl\n"
+ "dgrabbambj@imageshack.us\n"
+ "etossellbk@apple.com\n"
+ "smoodycliffebl@sogou.com\n"
+ "rtoothillbm@wisc.edu\n"
+ "asebbornbn@infoseek.co.jp\n"
+ "dgherardescibo@jalbum.net\n"
+ "aarnaldybp@europa.eu\n"
+ "aballantinebq@bigcartel.com\n"
+ "cgiraudatbr@phpbb.com\n"
+ "hmaccoughenbs@answers.com\n"
+ "emattessenbt@dot.gov\n"
+ "saronowbu@exblog.jp\n"
+ "ckorneichukbv@berkeley.edu\n"
+ "nroderigobw@yale.edu\n"
+ "ealeksandrevbx@netvibes.com\n"
+ "ebolterby@eepurl.com\n"
+ "cgaitherbz@theatlantic.com\n"
+ "sfeedomec0@shutterfly.com\n"
+ "ahatfullc1@ocn.ne.jp\n"
+ "mbythwayc2@whitehouse.gov\n"
+ "mleitherc3@dyndns.org\n"
+ "gtouretc4@icq.com\n"
+ "lmcnaec5@cam.ac.uk\n"
+ "tculveyc6@si.edu\n"
+ "fportwainc7@themeforest.net\n"
+ "eshivellc8@xing.com\n"
+ "mrheltonc9@howstuffworks.com\n"
+ "rrenodenca@walmart.com\n"
+ "ibaudcb@apple.com\n"
+ "amckerncc@domainmarket.com\n"
+ "aszymczykcd@vk.com\n"
+ "edittyce@patch.com\n"
+ "eibertcf@cyberchimps.com\n"
+ "apagencg@google.cn\n"
+ "bcousinsch@elpais.com\n"
+ "edockrellci@kickstarter.com\n"
+ "peasterlingcj@vkontakte.ru\n"
+ "mmoenck@mail.ru\n"
+ "nstitwellcl@admin.ch\n"
+ "mreginacm@techcrunch.com\n"
+ "fbindoncn@nps.gov\n"
+ "vpocklingtonco@seattletimes.com\n"
+ "lbarabichcp@privacy.gov.au\n"
+ "fmcbeathcq@thetimes.co.uk\n"
+ "jbohillscr@bandcamp.com\n"
+ "aworkescs@amazon.de\n"
+ "mmarusyakct@zdnet.com\n"
+ "lmcaleescu@simplemachines.org\n"
+ "bdemetzcv@illinois.edu\n"
+ "jdominiquecw@economist.com\n"
+ "easlottcx@ftc.gov\n"
+ "adewhirstcy@marriott.com\n"
+ "mstaddomcz@slideshare.net\n"
+ "aealamd0@ibm.com\n"
+ "dweblind1@youtube.com\n"
+ "palasdaird2@unesco.org\n"
+ "rfrearsond3@disqus.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}