package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<t>[^:=]*)(:(?<u>[^:=]*))?(:(?<v>[^:=]*))?=(?<value>.*)`)
var str = `AppSettings:Envionment:Other=Dev`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}