re = /(?<t>[^:=]*)(:(?<u>[^:=]*))?(:(?<v>[^:=]*))?=(?<value>.*)/m
str = 'AppSettings:Envionment:Other=Dev'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end