import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]{3})(20\\d{2})(\\d{9})\\b";
final String string = "PRK2017000003021\n"
+ "PRK2017000003017\n"
+ "AAA2017000000000\n"
+ "aaa2017956639163\n"
+ "Aaa2017956639163\n"
+ "AAa2017956639163\n"
+ "aAA2017956639163\n"
+ "DMY2017817027421\n"
+ "PRK2017000003022\n"
+ "PRK2017000003023\n"
+ "PRN2017000000001\n"
+ "IHR2018000000001\n"
+ "IHR2018000000002\n"
+ "IHR2018000000003a\n"
+ "DMY20180112150945";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}