// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Z]{3})(20\d{2})(\d{9})\b").unwrap();
let string = "PRK2017000003021
PRK2017000003017
AAA2017000000000
aaa2017956639163
Aaa2017956639163
AAa2017956639163
aAA2017956639163
DMY2017817027421
PRK2017000003022
PRK2017000003023
PRN2017000000001
IHR2018000000001
IHR2018000000002
IHR2018000000003a
DMY20180112150945";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}