using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=(.+)(?=&show_text)";
string input = @"https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2Fportateste%2Fvideos%2F1585186298555265%2F&show_text=0&width=560";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}