const regex = /href=(.+)(?=&show_text)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href=(.+)(?=&show_text)', 'g')
const str = `https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2Fportateste%2Fvideos%2F1585186298555265%2F&show_text=0&width=560`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}