$re = '/[A-ZА-Я][a-zа-я]+([A-ZА-Я][a-zа-я]+)+/';
$str = 'Scottybot Most Recent Code: BestDoggoEver';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);