re = /[A-ZА-Я][a-zа-я]+([A-ZА-Я][a-zа-я]+)+/
str = 'Scottybot Most Recent Code: BestDoggoEver'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end