#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[1.-][\s.-]\d{3}[\s.-]\d{3}[\s.-]\d{4}(\s+or\s+[1.-][\s.-]\d{3}[\s.-]\d{3}[\s.-]\d{4}(?!\S))?"
Local $sString = "1 203 455 0742" & @CRLF & _
"" & @CRLF & _
"1 203 265 9723" & @CRLF & _
"" & @CRLF & _
"+1-203-826-7522" & @CRLF & _
"" & @CRLF & _
"klhklkkkljugu 1-800-541-0487 7tgtiuguyfglyfgl" & @CRLF & _
"" & @CRLF & _
"Fill out the form below, or call 1-800-541-0487" & @CRLF & _
"" & @CRLF & _
"1 (203) 816 7500" & @CRLF & _
"" & @CRLF & _
"1 203 816 7511" & @CRLF & _
"1-203-445-0000" & @CRLF & _
"" & @CRLF & _
"1-208-687-4348 or 1-509-892-5779" & @CRLF & _
"" & @CRLF & _
"1-208-687-4348 or 1-509-892-5779" & @CRLF & _
"" & @CRLF & _
"Fill out the form below completely or call:" & @CRLF & _
"1-866-769-9533" & @CRLF & _
"" & @CRLF & _
"All fields with (*) are required. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")